Разработка в 1С 8.0




Примеры:


//1-йпример

Если Состав.Количество()=0 Тогда

   Предупреждение("Не указано ни одной строки!");

КонецЕсли;

//2-й пример

Если Сотр.Категория = Перечисления.Категории.Совместитель Тогда

   //обработаем как совместителя

Иначе

   //обычный сотрудник

КонецЕсли;

//3-й пример

Если выбор = 1 Тогда

   Сообщить("Выбран 1-й пункт");

ИначеЕсли выбор = 2 или выбор = 3 Тогда

   Сообщить("Выбран 2-й или 3-й пункт");

Иначе

   Сообщить("Обработка этого пункта не предусмотрена");

КонецЕсли;

Ключевые слова ИначеЕсли, Иначе и КонецЕсли желательно записывать с новой строки.Следующий пример показывает нежелательное форматирование оператора Если:  

   

//




Содержание  Назад  Вперед