Разработка в 1С 8.0


Глава 02


Общие модули
Модуль приложения
Модуль внешнего соединения
Модули прикладных объектов
Модули форм
Внимание!
Код:
Код:
Глобальный контекст
В контексте модуля приложения (или модуля внешнего соединения)
В контексте общего модуля
В контексте модуля прикладного объекта
В контексте модуля формы
В контексте модуля формы - часть 2
В контексте модуля формы - часть 3
В контексте модуля формы - часть 4
В контексте модуля формы - часть 5
В контексте модуля формы - часть 6
Null
Конструкция «Если ... Тогда»
Примеры:
Так делать не рекомендуется!
Конструкция «?(..., ..., ...)»
Пример:
Код:
Логические выражения
Например:
Например:
Другой пример:
Например:
Конструкция «Для ... По ... Цикл»
КонецЦикла;
Конструкция «Для Каждого ... Из ... Цикл»
Код:
Цикл
Продолжить;
Прервать;
КонецЦикла;
Код:
Код:
Пока
Код:
Цикл
Перейти
Код:
~След
:
Перейти
Прервать
Перейти
Конструкция «Попытка...Исключение»
Попытка
Исключение
Попытка
Исключение
Исключение...КонецПопытки
Код:
()
ВызватьИсключение;
Исключение...КонецПопытки
Процедура
Функция
Печать
Например:
КонецЕсли
КонецЕсли
Объявление переменных
Перем
Экспорт
Примеры:
Оператор Новый
Код:
Приведение типов
Системные перечисления и наборы значений
Код:
Код:
Код:
Окно редактора
Синтаксический контроль
Поиск и замена текста
Группировки конструкций языка
Синтакс-помощник
Контекстная подсказка
Шаблоны
Закладки по тексту
Разделение и слияние окон
Изменения во встроенных функциях, свойствах и методах глобального контекста:
Изменения во встроенных функциях, свойствах и методах глобального контекста: - часть 2
Изменения во встроенных функциях, свойствах и методах глобального контекста: - часть 3
Изменения во встроенных функциях, свойствах и методах глобального контекста: - часть 4
Изменения во встроенных функциях, свойствах и методах глобального контекста: - часть 5
Изменения во встроенных функциях, свойствах и методах глобального контекста: - часть 6



Начало    



Книжный магазин